Materi-Materi Persiapan LKS TKJ

 Kisi-Kisi Tahun 2015

  • Modul 1 : Integration Island 
  1. 1. VMWare Workstation configuration 
  2. 2. Debian 7.0 Operating system Installation 
  3. 3. Windows Server 2008 R2 Operating system Installation 
  4. 4. Windows 7 Operating System Installation 
  5. 5. RAID 

  6. Definisi RAID

         Masalah utama sistem memori adalah mengimbangi laju kecepatan CPU.
         Beberapa teknologi dicoba dan dikembangkan, diantaranya menggunakan konsep akses paralel pada disk.
         Kerja paralel menghasilkan resultan kecepatan disk yang lebih cepat.  
         RAID (Redundancy Array of Independent Disk) merupakan organisasi disk memori yang mampu menangani beberapa disk dengan sistem akses paralel dan redudansi yang ditambahkan untuk meningkatkan reliabilitas. 
         Teknologi database sangatlah penting dalam model disk ini karena pengontrol disk harus mendistribusikan data pada sejumlah disk dan juga pembacaan kembali.
         RAID (Redundancy Array of Independent Disk) merupakan salah satu jawaban masalah kesenjangan antara kecepatan prosesor dan elektromekanis disk drive yang relatif lambat.
         Strateginya adalah dengan mengganti disk berkapasitas besar dengan sejumlah disk drive berkapasitas kecil, dan mendistribusikan data sedemikian rupa sehingga memungkinkan akses data dari sejumlah drive secara simultan, yang akan meningkatkan kinerja I/O dan memungkinkan peningkatan kapasitas secara mudah. 
         Pola RAID terdiri dari enam tingkat, nol hingga enam.

    Karakteristik RAID 

    1.    RAID merupakan sekumpulan disk drive yang dianggap oleh sistem operasi sebagai sebuah drive logic tunggal.
    2.    Data didistribusikan ke drive fisik array
    3.    Kapasitas redundant disk digunakan untuk menyimpan informasi paritas, yang menjamin recoverability data ketika terjadi kegagalan disk. 
  7. 6. Partitioning 
  8. 7. Shell Scripting 
  9. 8. Cabling 
  10. 9. Network Installation 
  11. 10. Cisco Router 802.11Q Configuration 
  12. 11. Cisco Switch Vlan Configuration
    VLAN
    Pengertian VLAN
    VLAN (Virtual Local Area Network)  merupakan pengembangan dari LAN. VLAN adalah suatu model jaringan yang mirip dengan LAN namun tidak terbatas pada lokasi fisik. Oleh karena itu, jaringan ini dapat di konfigurasikan secara virtual dan tidak bergantung pada lokasi fisik peralatan. [1]

    Fungsi VLAN
    Penggunaan VLAN akan membuat pengaturan jaringan menjadi sangat fleksibel dimana dapat dibuat segmen yang bergantung pada organisasi atau departemen, tanpa bergantung pada lokasi workstation. [1]
           
    VLAN ID
    VLAN ID adalah suatu informasi yang ditambahkan pada setiap frame untuk mengijinkan pengiriman frame melalui switch mode trunk, serta untuk memberikan identitas sebuah VLAN dan digunakan nomor identitas VLAN yang dinamakan VLAN ID. Dalam menandai VLAN yang terkait terdapat dua range VLAN ID yaitu:
        1.      Normal Range VLAN (1 – 1005)
             digunakan untuk jaringan skala kecil dan menengah.
             Nomor ID 1002 s.d. 1005 dicadangkan untuk Token Ring dan FDDI VLAN. 
             ID 1, 1002 - 1005 secara default sudah ada dan tidak dapat dihilangkan.
             Konfigurasi disimpan di dalam file database VLAN, yaitu vlan.dat. file ini disimpan dalam memori flash milkik switch.
             VLAN trunking protocol (VTP), yang membantu manaejemn VLAN, nanti dipelajari di bab 4, hanya dapat bekerja pada normal range VLAN dan menyimpannya dalam file database VLAN.
        2.      Extended Range VLANs (1006 – 4094)
             memampukan para seervice provider untuk memperluas infrastrukturnya kepada konsumen yang lebih banyak. Dibutuhkan untuk perusahaan skala besar yang membutuhkan jumlah VLAN lebih dari normal.
             Memiliki fitur yang lebih sedikit dibandingakn VLAN normal range.
             Disimpan dalam NVRAM (file running configuration).
             VTP tidak bekerja di sini.
    Switch catalys 2960 mendukung 255 normal range dan extended range. [1]

    Tipe-tipe VLAN
    Data VLAN
    Sebuah VLAN data adalah VLAN yang dikonfigurasi untuk hanya membawa user-generated lalu lintas. Sebuah VLAN dapat membawa suara berbasis trafik atau lalu lintas digunakan untuk mengelola saklar, namun lalu lintas ini tidak akan menjadi bagian dari VLAN data. Ini adalah praktek umum untuk memisahkan lalu lintas suara dan manajemen dari lalu lintas data. Pentingnya memisahkan data pengguna dari data switch control manajemen dan lalu lintas suara disorot oleh penggunaan istilah khusus yang digunakan untuk mengidentifikasi VLAN yang hanya membawa data pengguna - sebuah "data VLAN". Sebuah VLAN data kadang-kadang disebut sebagai VLAN pengguna.

    Default VLAN
    Semua port switch menjadi anggota VLAN default setelah boot up awal dari saklar. Memiliki semua port switch berpartisipasi dalam VLAN default membuat mereka semua bagian dari domain broadcast yang sama. Hal ini memungkinkan setiap perangkat yang terhubung ke port switch untuk berkomunikasi dengan perangkat lain pada port switch lainnya. Default VLAN untuk switch Cisco adalah VLAN 1. VLAN 1 memiliki semua fitur dari setiap VLAN, kecuali bahwa Anda tidak dapat mengubah nama itu dan Anda tidak dapat menghapusnya. Layer 2 kontrol lalu lintas, seperti CDP dan mencakup lalu lintas protokol pohon, akan selalu dikaitkan dengan VLAN 1 - ini tidak dapat diubah. Dalam gambar, VLAN 1 lalu lintas diteruskan selama batang VLAN menghubungkan switch S1, S2, dan S3. Ini adalah praktek keamanan terbaik untuk mengubah default VLAN ke VLAN lain dari VLAN 1; ini memerlukan mengkonfigurasi semua port pada switch untuk dihubungkan dengan default VLAN selain VLAN 1. Batang VLAN mendukung transmisi lalu lintas dari lebih dari satu VLAN. Meskipun VLAN batang disebutkan seluruh bagian ini, mereka dijelaskan pada bagian berikutnya pada trunking VLAN.

    Catatan: Beberapa administrator jaringan menggunakan "VLAN default" untuk berarti VLAN selain VLAN 1 didefinisikan oleh administrator jaringan sebagai VLAN bahwa semua port yang ditugaskan untuk ketika mereka tidak digunakan. Dalam hal ini, peran hanya itu VLAN 1 memainkan adalah bahwa penanganan Layer 2 kontrol lalu lintas untuk jaringan.

    Native VLAN
    Sebuah VLAN asli ditugaskan ke port trunk 802.1Q. Sebuah port trunk 802.1Q mendukung lalu lintas yang datang dari banyak VLAN (tagged traffic) serta lalu lintas yang tidak datang dari sebuah VLAN (untagged lalu lintas). Port trunk 802.1Q menempatkan untagged lalu lintas pada VLAN asli. Dalam gambar, VLAN asli adalah VLAN 99. Lalu lintas untagged dihasilkan oleh komputer terpasang ke port switch yang dikonfigurasi dengan VLAN asli. VLAN asli ditetapkan dalam spesifikasi IEEE 802.1Q untuk menjaga kompatibilitas dengan lalu lintas tanpa tanda umum untuk skenario warisan LAN. Untuk tujuan kita, VLAN asli berfungsi sebagai pengenal umum pada lawan ujung sebuah link trunk. Ini adalah praktek terbaik untuk menggunakan VLAN selain VLAN 1 sebagai VLAN asli.

    Management VLAN
    Sebuah VLAN manajemen adalah setiap VLAN Anda mengkonfigurasi untuk mengakses kemampuan manajemen dari switch. VLAN 1 akan melayani sebagai VLAN manajemen jika Anda tidak secara proaktif menentukan VLAN unik untuk melayani sebagai VLAN manajemen. Anda menetapkan VLAN manajemen alamat IP dan subnet mask. Switch dapat dikelola melalui HTTP, Telnet, SSH, atau SNMP. Karena konfigurasi out-of-the-box sebuah switch Cisco memiliki VLAN 1 sebagai VLAN default, Anda melihat bahwa VLAN 1 akan menjadi pilihan yang buruk sebagai VLAN manajemen; Anda tidak ingin pengguna sewenang-wenang menghubungkan ke saklar untuk default ke VLAN manajemen. Ingat bahwa Anda mengkonfigurasi VLAN manajemen VLAN 99 di Konsep Beralih Dasar dan bab Konfigurasi.

    Pengertian Mode Access dan Trunk

      Mode Access adalah mengatur config yang ada pada suatu vlan agar terhubung dengan jaringan vlan yang lainnya.
      Trunk pada VLAN adalah link point-to-point diantara satu atau lebih dari interface Ethernet dan perangkat lain jaringan, yang dimana merupakan saluran untuk VLAN antara switch dan router. Trunk membawa lalu lintas untuk memperluas VLAN melintasi seluruh jaringan. [1]

    Proses Tagging pada VLAN
    VLAN Tagging adalah sebuah standar jaringan yang ditulis oleh kelompok kerja IEEE 802.1 mengizinkan beberapa jaringan bridge untuk transparan berbagi link jaringan fisik yang sama tanpa kebocoran informasi antara jaringan. IEEE 802.1Q - bersama dengan bentuk singkat dot1q - biasanya digunakan untuk merujuk pada protokol enkapsulasi yang digunakan untuk menerapkan mekanisme ini melalui jaringan Ethernet.
    IEEE 802.1Q mendefinisikan arti dari sebuah Virtual LAN (VLAN) yang berkaitan dengan model konseptual tertentu yang mendukung bridging pada lapisan MAC dan 802.1D IEEE protokol spanning tree. Protokol ini memungkinkan untuk setiap VLAN untuk berkomunikasi dengan satu sama lain dengan menggunakan sebuah switch dengan kemampuan lapisan-3, atau router. [2]

    Konfigurasi VLAN dan TRUNKS

    Buat Database VLAN pada Switch.
    Switch>enable
    Switch#vlan
    Switch#vlan database
    Switch(vlan)#vlan 2 name guest
    VLAN 2 added:
    Name: guest
    Switch(vlan)#vlan 3 name student
    VLAN 3 added:
    Name: student
    Switch(vlan)#vlan 4 name lecture
    VLAN 4 added:
    Name: lecture
    Switch(vlan)#exit
    APPLY completed.
    Exiting….
    Switch#
    Masuk ke Global Configuration Mode dan lakukan Grouping Port.
    Switch#configure terminal
    Switch(config)#interface fastEthernet 0/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 2
    Switch(config-if)#exit
    Switch(config)#interface fastEthernet 0/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 2
    Switch(config-if)#exit
    Switch(config)#interface fastEthernet 0/3
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 3
    Switch(config-if)#exit
    Switch(config)#interface fastEthernet 0/4
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 3
    Switch(config-if)#exit
    Switch(config)#interface fastEthernet 0/5
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 4
    Switch(config-if)#exit
    Switch(config)#interface fastEthernet 0/6
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 4  [3]
  13. 12. Cisco Static Routing Configuration 
  14. 13. Cisco Router Network Address Translation Configuration
  15. Set ip address untuk WAN
    R1#conf t
    R1(config)#int f0/0
    R1(config-if)#ip add 192.168.137.2 255.255.255.0
    R1(config-if)#ip nat outside
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#

    Set ip address untuk LAN
    R1(config)#int f1/0
    R1(config-if)#ip add 10.1.1.1 255.255.255.248
    R1(config-if)#ip nat inside
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#

    Set default gateway dan NAT
    R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.137.1
    R1(config)#ip nat inside source list 1 int f0/0 overload
  16. 14. Cisco Router Access Control List 
  17. 15. Cisco telnet configuration   
  18. 1. Router> enable
    2. Router# configure terminal
    3. Router(config)# line vty 0 4
    4. Router(line-vty)# password your_pass
    5. Router(line-vty)# login
    6. Router(line-vty)# exit
    7. Router(config)# enable password your_pass
    ket :
    1. line vty ==> perintah untuk mengaktifkan/mensetting telnet
    2. 0 4 ==> jumlah user/session yang bisa mengakses waktu yang sama
    3. password ==> untuk setting password telnet
    4. login ==> untuk mengaktifkan password telnet
    5. enable password ==> untuk mengaktifkan enable password pada router
  19. 16. Services Installation and configuration:
    a. Active Directory Server (Add user, User & Group Management, Group Policy, Roaming Profile, Home Folder Share Folder, Map Drive)
    b. DNS Server
    c. DHCP Server
    d. Mail & Webmail server
    e. RAID
    f. VPN
    g. Join Domain 
  • Modul 2 : Linux Island 
  1. 1. VMWare Workstation Configuration 
  2. 2. Debian 7.0 Operating system Installation 
  3. 3. Debian router, server and client configuration 
  4. 4. Shell Scripting 
  5. 5. Network Installasation
  6.  6. Routing Configuration 
  7. 7. Proxy Configuration 
  8. 8. Firewall Configuration 
  9. Semua settingan IPTABLES terdapat pada
    # nano /etc/rc.local
    kemudian anda tinggal masukan RULE IPTABLES sebelum tulisan exit 0

    a) Blok Ip yang Masuk,
    iptables –A INPUT –s 192.168.12.1 –j DROP

    b) Blok Subnet yang Masuk,
    iptables –A INPUT –s 192.168.12.0/24 –j DROP

    c) Blok Interface yang Masuk,
    iptables –A INPUT –o eth0 –j DROP

    Blok Outgoing Packet
    Diatas adalah beberapa konfigurasi untuk memblokir paket yang masuk, dan berikut di bawah untuk memblokir paket yang keluar.

    d) Blok Ip yang Keluar,
    iptables –A OUTPUT –d 192.168.12.1 –j DROP

    Blok Specified Port
    Dalam pembahasan selanjutnya, kita akan mengkonfigurasi pemblokiran pada port protocol tertentu. Sebelumnya, anda harus mengetahui terlebih dahulu, nama protocol beserta port yang sering digunakan. Komputer kita terdapat kurang lebih 35.000 nomor port. Dan berikut port-port yang sering dipakai.

    1. FTP (21)
    2. SSH (22)
    3. TELNET (23)
    4. SMTP (25)
    5. DNS (53)
    6. TFTP (69)
    7. HTTP (80)
    8. POP3 (110)
    9. IMAP (143)
    10. HTTPS (443)


    Sebagai permisalan, disini saya akan memblokir port FTP agar tidak bisa diakses.
    a) Blok Port yang Masuk,
    iptables –A INPUT -p tcp --dport 21 –j DROP

    b) Blok dari Subnet tertentu,
    iptables –A INPUT -s 192.168.12.0/24 –p tcp --dport 21 –j DROP

    Allow Specified Port Only
    Diatas adalah beberapa konfigurasi untuk memblokir, dan berikut jika kita mengijinkan Ip Tertentu saja yang bisa mengakses protocol tersebut.
    c) Ijinkan Ip tertentu,
    iptables –A INPUT –s 192.168.12.7 –j ACCEPT

    d) Ijinkan Interface tertentu untuk mengakses FTP,
    iptables –A INPUT –o eth1 –p tcp --dport 21 –j ACCEPT
  10. 9. Network Monitoring configuration (Cacti) 
  11. 10. Services Installation and configuration: (hasil praktikum ada di folder Jurusan, source debservfinal.pdf)
    a. SSH Server
    b. File Server / samba
    c. NTP Server
    d. Web Server (HTTP & HTTPS)
    e. DNS Server
    f. FTP Server
    g. DHCP Server  
  • Modul 3 : Cisco Packet Tracer 
  1. 1. Subnetting (VLSM / CIDR) OK
  2. 2. Server PT configuration (DHCP, DNS, WEB Server) OK
  3. 3. Basic Router and Switch Cisco Configuration 
  4. 4. 802.1Q --> VLAN
  5. 5. Inter Vlan Routing OK
  6. 6. Static dan Dynamic Routing configuration OK

Berkomentarlah yang saling membangun dan sesuai topik yang diisajikan,
Dilarang menyematkan hal yang berbau link dan berkomentar kotor.
EmoticonEmoticon